United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

KY DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 16, 2024 - 23:42 UTC
Identified
The KY DMV will be performing scheduled maintenance from Friday, December 29 at 9pm pacific through Friday, January 12 at 2pm pacific. It is possible that maintenance will complete earlier in the week of January 8 and we will provide updates as they become available. MVRs requested during the maintenance window will not be completed until the scheduled maintenance is completed.
Posted Dec 28, 2023 - 16:47 UTC