United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Alexandria City, VA
Incident Report for Checkr US Data Status
Resolved
The Alexandria City Circuit court migration is complete and back to normal operations. Please expect some delays in this jurisdiction while our researchers work through searches.
Posted Sep 23, 2024 - 14:44 UTC
Monitoring
The Alexandria City Circuit court migrated to a new case management system. Please expect delays on all searches. We will continue to monitor the situation and will notify you of any changes.
Posted Sep 11, 2024 - 15:11 UTC