United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Hurricane Milton Closures and Delays
Incident Report for Checkr US Data Status
Resolved
The impacted courts have reopened. Please anticipate delays as our researchers work through searches.
Posted Oct 16, 2024 - 18:42 UTC
Monitoring
Hurricane Milton is expected to make landfall in Florida tomorrow. Please anticipate delays. We’re closely monitoring the situation and will provide updates as more information becomes available.

The following courts are closing due to the impending hurricane, and research will resume once they reopen:
--Brevard, Charlotte, Citrus, Collier, DeSoto, Glades, Hendy, Hernando, Hillsborough, Lake, Lee, Manatee, Marion, Okeechobee, Pasco, Pinellas, Sarasota, Seminole, and Sumter.
Posted Oct 08, 2024 - 19:32 UTC