United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] - Parker, TX
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 12, 2023 - 23:17 UTC
Update
We are continuing to monitor for any further issues.
Posted May 11, 2023 - 18:35 UTC
Update
We are continuing to monitor for any further issues.
Posted May 09, 2023 - 23:48 UTC
Monitoring
The online index is offline in Parker, TX. Currently there is no ETA of a fix. This closure affects all searches. Please expect delays.
Posted May 03, 2023 - 16:19 UTC