United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] West Virginia DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 17:12 UTC
Identified
The West Virginia DMV will be performing scheduled maintenance today from 6-9pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Nov 08, 2022 - 17:42 UTC