United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 13, 2024 - 16:41 UTC
Identified
The following DMV will be performing scheduled maintenance on Sunday, 5/12:

Wisconsin: 3:30-5:30am PT

MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted May 10, 2024 - 22:11 UTC