United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Colorado DMV is Offline

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Sep 24, 2024 - 17:01 UTC

Investigating

The Colorado DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Sep 19, 2024 - 22:03 UTC