United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Bibb County, GA – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved- normal search processing has resumed
Posted May 08, 2026 - 18:34 UTC

Monitoring

Updates to the court portal have taken some automated search processing offline in Bibb County, GA. Searches are being fulfilled manually in the interim; please expect delays. No ETA for resolution at this time.
Posted May 05, 2026 - 01:07 UTC

Investigating

Updates to the court portal have taken some automated search processing offline in Bibb County, GA. Searches are being fulfilled manually in the interim; please expect delays. No ETA for resolution at this time.
Posted May 01, 2026 - 00:05 UTC