United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Harrison, TX
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 16:06 UTC
Monitoring
The County and District court system is down. No searches can be processed until the court system is functional. There is no ETA for when the court system will be fixed. We will continue to monitor the situation and will notify you of any changes.
Posted Nov 23, 2022 - 17:25 UTC