United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Georgia DMV Planned Outage
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 15:44 UTC
Identified
12/29/2021: The Georgia online DMV is planning to have an extended outage starting Thursday 12/30/21 at 6 PM and will be back online Tuesday 1/4/22 at 6 AM. Any orders that are requested during this time will not be completed.
Posted Dec 29, 2021 - 23:19 UTC