United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Cesar Chavez Day
Incident Report for Checkr US Data Status
Resolved
All California courts were closed yesterday, March 31st, in observation of Cesar Chavez Day. Courts have since reopened. Please keep in mind that some California courts may still be closed due to COVID-19.
Posted Apr 01, 2020 - 18:27 UTC
Identified
Expected Fix Date: 4/1/2020

All California courts will be closed tomorrow, March 31st, in observation of Cesar Chavez Day. Please expect a slight delay.
Posted Mar 30, 2020 - 18:33 UTC