United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 20:21 UTC
Monitoring
Medium Impact
--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--GA: Bibb - Currently only one public access terminal is functioning in State Court, while the second terminal is out of service with no estimated date for repair. We are processing searches but please anticipate delays.
--NV: Clark - The public access terminal is currently experiencing intermittent degradation and slowness, with no estimated time for repair. Please anticipate delays.

Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--TN: McNairy - The PAT is currently down with no ETA for restoration. Please anticipate delays.
Posted Nov 06, 2024 - 20:49 UTC