United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Washington, MS is Offline
Incident Report for Checkr US Data Status
Resolved
07/15/2021: The Washington, MS online court system is back online and searches can now be completed.
Posted Jul 15, 2021 - 20:40 UTC
Monitoring
7/12/2021: The Washington, MS online court system is currently still offline. The new ETA for when it will be back online is July 14th, 2021. We will continue to monitor this and keep you updated.
Posted Jul 12, 2021 - 19:58 UTC
Identified
07/07/2021: The Washington, MS online court system is currently offline. The court is replacing their server for their record-keeping system. We are in communication with the courts, and they are expecting this to be back online by Monday, July 12th, 2021.

*This will affect all searches*
Posted Jul 07, 2021 - 14:53 UTC