United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Upcoming DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 16, 2024 - 23:23 UTC
Identified
The following DMVs will be performing scheduled maintenance during the windows stated below over the coming days (all times Pacific):

- Florida: Thursday, January 4 from 4pm to 9pm Pacific
- Tennessee: Friday, January 5 from 6am to 10am Pacific

MVRs requested in these states during these windows will not be completed until the scheduled maintenance is completed.
Posted Jan 04, 2024 - 23:02 UTC