Data Status Page

This page contains information about third-party data source disruptions and delays.

Multi Product - Temporary Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved- normal search processing has resumed
Posted Jul 18, 2026 - 14:26 UTC

Monitoring

We are monitoring a technical issue with one of our third-party data providers that could lead to longer than normal turnaround times. No ETA for resolution at this time.
Posted Jul 18, 2026 - 10:51 UTC