United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Dougherty, GA Closure
Incident Report for Checkr US Data Status
Resolved
04/12/2021: The Dougherty, GA Courts are back open.
Posted Apr 12, 2021 - 20:23 UTC
Identified
ETA: 04/12/2021

04/08/2021: Dougherty, GA County Courts have been closed due to a main water break. They are expected to reopen on Monday, April 12th, but we will continue to monitor this and provide new ETAs if necessary.

*This will only affect reports with possible cases*
Posted Apr 08, 2021 - 20:16 UTC