United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 07, 2022 - 17:00 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Friday, 11/4 to Saturday, 11/5
Massachusetts: 10pm-4am PT

Saturday, 11/5
Wyoming: 7-9am PT

Saturday, 11/5 to Sunday, 11/6
Kentucky: 10pm-5am PT
New Jersey: 10:30pm-12:30am PT

Sunday, 11/6
Pennsylvania: 1-7am PT
New Jersey: 4-6am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.

**Please note that New Jersey is intentionally listed twice. We received notice of two separate maintenance windows.
Posted Nov 04, 2022 - 19:09 UTC