United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Possible Cases out of Clayton, GA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 19:28 UTC
Update
03/30/2021: Our researchers are still seeing these same delays with both the Superior Court and the State Court in Clayton, GA. There are limited clerk appointments available for all researchers and they are only allowing a certain amount of cases to be released per day, so this is causing ongoing delays. We will continue to monitor this.
Posted Mar 30, 2021 - 23:20 UTC
Identified
ETA: Unknown

1-14-2021: As many of you have noticed, possible case details out of CLAYTON, GA are delayed. The courts have implemented the following restrictions:

SUPERIOR COURT:
-In this location, it is nearly impossible to get an appointment due to limited court capacity, high
security regulation, and the competition amongst researchers for appointment slots.
-Superior court is operating on an appointment-only basis and each appointment has a 2-hour time
limit.
-Security will turn away researchers if they don’t provide proof of appointment- i.e. email
exchange or by calling the clerks to confirm.
-Appointment slots are on a first come first serve basis.
-This court also only lets in four researchers a day to complete research- two in the morning and
two in the afternoon
-Each Researcher must be escorted to and from the clerk’s department- no one can wander freely
about the campus- Each 2-hour appointment begins the moment the researcher arrives, regardless
of time waiting for clerk escort
-During the appointment time, there is access to the PAT, but we must utilize clerk assistance to
verify DOB’s.
-The system on the PAT in Superior court only has some DOB’s available. If a DOB cannot be
found, then a clerk will need to be consulted to verify them in person.
-Any special sentencing information (i.e. drug testing, community service, etc.) is not listed on
the PAT and requires clerk verification
-Multiple providers have confirmed that within their two-hour appointment window an average of
3 orders (30 records) can be completed.

STATE COURT:
-State court is currently closed and not letting anyone physically in, however, the court is still
offering virtual clerk assistance to obtain copies of case information.
-The PAT system is utilized virtually through the Clayton County website to obtain basic
information for State court cases.
-DOB's are not available and court copies must be obtained for identifiers.
-The clerk is only sending copies for 5 names and/or case numbers per day.
-The clerk also works from home and only goes into the office a maximum of 2 days a week, so if
there are any cases that are on microfilm the vendor then has to wait until the clerk goes into the
office to retrieve the information.
-Our researchers are meeting on the issues in Gwinnett daily in an attempt to devise a plan to increase capacity, but do not have an update at this time.

In addition to these changes, in preparation for inauguration day, security has been drastically increased. As of this week, there are now 5 armed guards at the entry point of the courthouse.

We sincerely apologize for the inconvenience this may cause and will continue to work with our researchers to try to increase capacity as quickly as possible.

*Please note that this delay does not affect clear results, only searches with possible cases.*
Posted Jan 14, 2021 - 16:00 UTC