United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Cameron, LA
Incident Report for Checkr US Data Status
Resolved
9/29/2020: The Cameron, LA court has reopened. This jurisdiction is only accessible by boat and there are often floods which prevent accessibility, so it is possible it may close in the near future. Another update will be posted if Cameron, LA closes again.
Posted Sep 29, 2020 - 18:23 UTC
Identified
Expected Fix Date: TBD

9/11/2020: Please note that Cameron, LA is currently closed due to hurricane damage. There is no ETA as to when the court will reopen, but an update will be posted when it does.
Posted Sep 11, 2020 - 20:06 UTC