03/11/2022: Covid Closures and General Delays
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Mar 25, 2022 - 18:29 UTC
Monitoring
Closed Counties:
- Not available

Delayed Counties
Listed in order of impact on pending reports

High Impact
–CA: Santa Clara- Searches must be conducted by the clerks and there are in-court restrictions causing major delays.
--IL: Cook- The entire research community has lost capacity in Cook, IL due to staffing issues among several of the largest researchers servicing the county. Checkr is working with local researchers to increase capacity and improve turnaround time. Please expect delays for the foreseeable future.

Medium Impact

CA: San Bernardino- Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
El Dorado- The online system is offline and searches must be conducted by clerks.
Marin- Searches must be conducted by the clerks and there are in-court restrictions causing major delays.
San Diego- All possible records must be submitted to the clerks in order to get complete information.
Solano- All possible records must be submitted to the clerks in order to get complete information.
Merced- Searches must be conducted by the clerks and there are in-court restrictions causing major delays.
–GA: Clayton- Complete information on possible hits is missing for many cases.
Fulton- Complete information on possible hits is missing for many cases.
--HI: Honolulu - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
--MA: Many searches require files to be pulled and files can only be pulled by the court clerks. Additional delays can occur based on staffing in the court or other demands of the clerks time. Expect delays.
Washington, DC- Searches must be conducted by the clerks and there are in-court restrictions causing major delays.

Low Impact

-Ventura, CA: The court is experiencing staff limitations and limited hours please expect delays on orders with possible cases.
Yellowstone, MT- The courts have limited appointments for our researchers to 1 hour. Please expect delays.
**Washoe, NV: The court is experiencing staff limitations and limited hours please expect delays.
--TX: Lubbock - Complete information on possible hits can only be obtained in the courthouse. The court is limiting how frequently researchers can visit. Please expect delays.

New Re-opened Counties:
- Not available

**New Closure or Delay
Posted Mar 11, 2022 - 21:13 UTC