[Closure] Tallahatchie, MS Closure
Incident Report for Checkr Data Status
Resolved
04/06/2021: Tallahatchie, MS courts are back open.
Posted Apr 06, 2021 - 15:09 UTC
Identified
ETA: 04/01/2021

03/08/2021: Tallahatchie, MS county courts will be closed until the beginning of April due to a movie production that is occuring at the courts. We will continue to monitor the status, but they are currently are planning to re-open 04/01/2021.

*This will affect all searches*
Posted Mar 08, 2021 - 20:56 UTC