[Planned Outage] South Carolina DMV
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 16:08 UTC
Monitoring
The South Carolina DMV plans to have an extended outage from July 22, 2022, to July 24, 2022. No MVRs requested during this time will be completed. We apologize in advance for the inconvenience.
Posted Jul 22, 2022 - 19:10 UTC