[Outage] Louisiana DMV is Offline
Incident Report for Checkr Data Status
Resolved
The Louisiana online DMV is back online and orders are now able to be processed.
Posted Nov 15, 2021 - 20:54 UTC
Identified
11/15/2021: The Louisiana online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Nov 15, 2021 - 15:55 UTC