United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Courts Affected by Hurricane Sally
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 20:08 UTC
Update
9/21/2020: All counties below that were impacted by Hurricane Sally are now open.

Bay, FL
Escamba, FL
Santa Rosa, FL
Walton, FL
Posted Sep 21, 2020 - 17:40 UTC
Identified
Expected Fix Date: TBD

9/17/2020: Below is the current list of court closures due to Hurricane Sally. Please note that clear searches will continue to process as usual. All other searches will be impacted.

Bay, FL
Escamba, FL
Santa Rosa, FL
Walton, FL
Posted Sep 18, 2020 - 00:27 UTC