United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Travis County Delays
Incident Report for Checkr US Data Status
Resolved
Travis County is now fully operational.
Posted Jan 11, 2021 - 16:53 UTC
Identified
Expected Fix Date: TBD

1/06/2020: The Travis County Public Access Terminal started having technical difficulties on Monday, January 4th, and ultimately went down. The Travis County IT team was unable to give our researchers an exact ETA for when the PAT should be back up, but we will notify you when we know more. Clears will still be completed like normal, the outage only affects searches with potential hits.
Posted Jan 06, 2021 - 19:59 UTC