United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Motor Vehicle Reports are currently unavailable
Incident Report for Checkr US Data Status
Resolved
4/16/21 4:30pm PDT: This outage has been resolved and MVRs are now processing normally.
Posted Apr 16, 2021 - 23:35 UTC
Identified
4/16/21 2:30pm PDT: Motor Vehicle Reports (MVRs) are currently unavailable. Checkr is aware of the outage and is actively working on a resolution.
Posted Apr 16, 2021 - 21:38 UTC