United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] KY Courts Closed due to Ice Storm
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 17:29 UTC
Identified
ETA: 02/12/2021

02/11/2021: Many KY County Courts will be closed today due to an Ice Storm. At this time, it is confirmed that the following courts are closed: Bullitt, Jefferson, Henderson, Kenton, Boone. The courts should be open tomorrow morning, but we will monitor this throughout the day.

*This will affect all reports from being completed.*
Posted Feb 11, 2021 - 16:02 UTC