United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Tennessee DMV Maintenance 8/12 - 8/15
Incident Report for Checkr US Data Status
Resolved
The Tennessee DMV is back online.
Posted Aug 15, 2022 - 18:25 UTC
Identified
The Tennessee DMV will be offline on Friday, August 12 at 4:30pm CDT until the morning of Monday, August 15 for scheduled maintenance. MVRs will be unavailable in the state during this time and MVRs ordered during this time will be completed once service is restored.
Posted Aug 09, 2022 - 19:50 UTC