[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Oct 31, 2022 - 16:04 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Saturday, 10/29
Mississippi: 10am-3pm PT

Sunday, 10/30
Pennsylvania: 12-6am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Oct 28, 2022 - 18:55 UTC