United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] TN DMV Planned Outage
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 14:53 UTC
Identified
Outage Dates: 04/16/2021 to 04/19/2021

The Tennessee DMV has scheduled online system maintenance starting on Friday, April 16th through Monday, April 19th.
Posted Apr 13, 2021 - 19:42 UTC