United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] GA DMV Offline
Incident Report for Checkr US Data Status
Resolved
04/02/2021: GA DMV is back online.
Posted Apr 02, 2021 - 16:10 UTC
Identified
04/01/2021: The Georgia DMV is experiencing an outage and MVRs in the state are currently unavailable. We are in contact with the state to get an understanding of the issue and when service might resume.
Posted Apr 01, 2021 - 19:27 UTC