[Planned Closure] California Courts
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 16:38 UTC
Identified
03/31/2022: All California courts will be closed today for Cesar Chavez Day. The courts will re-open the following day, April 1st.

*This will only affect possible cases that require in court research*
Posted Mar 31, 2022 - 17:24 UTC