[Delay] Travis, TX
Incident Report for Checkr Data Status
Resolved
3/12/2020: Court access was unavailable for a few days but is now operational again.
Posted Mar 12, 2020 - 21:37 UTC
Identified
Expected Fix Date: TBD

3/9/2020: Please expect delays in Travis, TX as court access is currently unavailable.
Posted Mar 09, 2020 - 12:00 UTC