[Closure] Massachusetts Courts Closed - 4/18
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 15:06 UTC
Investigating
All Massachusetts courts will be closed on Monday, April 18 in observance of Patriot's Day. No searches can be completed in the state until courts reopen on Tuesday, April 19.
Posted Apr 15, 2022 - 20:43 UTC