United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Oregon DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The OR DMV is back online.
Posted Aug 04, 2022 - 21:45 UTC
Monitoring
The Oregon DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Aug 04, 2022 - 19:57 UTC