United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Closure] Jefferson, Kentucky 5/4-5/6
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 09, 2022 - 17:11 UTC
Identified
5/3/2022: Jefferson, Kentucky court is planning to close early on Wednesday and Thursday due to the Kentucky Derby. The court will close for the entire day on Friday, May 6th. No searches will be processed until the court reopens. We will continue to monitor the situation and notify you of any changes.
Posted May 03, 2022 - 17:54 UTC