Harris, TX Delays
Incident Report for Checkr Data Status
Resolved
1/26/2022: The Harris, TX online court system is back online and researchers are now able to complete searches.
Posted Jan 26, 2022 - 21:10 UTC
Identified
1/25/2022: The Harris, TX online court system has made changes to their website causing major delays in searches completing. There is currently no ETA for when this will be back up and running, but we will keep you updated as we know more.
Posted Jan 25, 2022 - 17:31 UTC