United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

KY Counties Closed due to Flooding
Incident Report for Checkr US Data Status
Resolved
08/10/2022: Knott county courthouse is the only court that remains closed due to the KY floods.
Posted Aug 10, 2022 - 16:26 UTC
Update
08/05/2022: The only remaining closed courts in KY due to the flooding are: Letcher and Knott. Please still expect some delays across the state of Kentucky as they continue to recover.
Posted Aug 05, 2022 - 15:36 UTC
Update
08/03/2022: The following counties in KY are still closed: Breathitt, Floyd, Harlan, Johnson, Knott, Lee, Letcher, Magoffin, Perry, Pike, and Powell.
Posted Aug 03, 2022 - 21:11 UTC
Monitoring
08/02/2022: Various counties across Kentucky are currently closed due to flooding across the state. This will affect all searches. Below is a list of counties known to be closed until further notice. We will continue to monitor this.
Kentucky:
Breathitt, Elliott, Estill, Floyd, Harlan, Johnson, Knott, Lee, Letcher, Magoffin, Martin, Menifee, Morgan, Perry, Pike, Powell, and Wolfe
Posted Aug 02, 2022 - 14:18 UTC