United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 15:26 UTC
Identified
The Florida DMV will be performing scheduled maintenance on Sunday, 3/26 from 4am-7pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Mar 24, 2023 - 00:14 UTC