United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Jersey DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The New Jersey DMV is back up and running.
Posted Jul 26, 2021 - 22:10 UTC
Identified
07/26/2021: The New Jersey online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Jul 26, 2021 - 20:15 UTC