United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] King, WA
Incident Report for Checkr US Data Status
Resolved
11/17/2021: The King, WA online court system is back online and orders are able to be processed.
Posted Nov 17, 2021 - 16:35 UTC
Identified
11/16/2021: The King, WA online court system is currently down and all searches are unable to be processed. There is currently no ETA of when this should be back online. We are continuing to monitor this and will notify you of any changes. *Estimate of affected reports: 0.8%*
Posted Nov 16, 2021 - 20:54 UTC