[Outage] Mississippi DMV is Offline
Incident Report for Checkr Data Status
Resolved
1/18/2022: The Mississippi DMV is back online and orders will now be able to be processed.
Posted Jan 18, 2022 - 20:23 UTC
Identified
1/18/2022: The Mississippi online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Jan 18, 2022 - 16:51 UTC