United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Mississippi DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The Mississippi DMV is back online and MVRs are once again processing as normal.
Posted Nov 02, 2022 - 14:49 UTC
Identified
The Mississippi DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Nov 01, 2022 - 16:40 UTC