United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Possible Cases out of Hampden, MA
Incident Report for Checkr US Data Status
Resolved
10/19/2021: The Hampden, MA courthouse is now open and searches are able to be processed. Please expect some delays.
Posted Oct 19, 2021 - 17:29 UTC
Update
10/01/2021: The Hampden, MA courthouse is still closed for mold, and searches with possible records are still unable to be completed. We are continuing to monitor this and will send you any updates.
Posted Oct 01, 2021 - 18:13 UTC
Update
09/20/2021: The Hampden, MA courthouse is still closed for mold, and searches with possible records are still unable to be completed. We are continuing to monitor this and will send you any updates.
Posted Sep 20, 2021 - 19:02 UTC
Update
09/17/2021: The Hampden, MA courthouse is still closed for mold, and searches with possible records are still unable to be completed. We are continuing to monitor this and will send you any updates.
Posted Sep 17, 2021 - 16:02 UTC
Monitoring
09/07/2021: The Hampden, MA courthouse is still closed for mold, and searches with possible records are still unable to be completed. We are continuing to monitor this and will send you any updates.
Posted Sep 07, 2021 - 20:36 UTC
Identified
09/01/2021: The Hampden, MA courthouse is currently closed for mold. The researchers are able to complete most searches here, but reports with possible records will be delayed. There is no ETA for when this will be back open.

*This will not affect all searches*
Posted Sep 01, 2021 - 20:52 UTC