[Court Holiday] CA Court Holiday
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 15:43 UTC
Identified
03/29/2021: On Wednesday, March 31st, all California courts will be closed for Cesar Chavez Day. The courts will re-open the following day, April 1st.

*This will affect most reports, as the majority of the counties in CA rely on court access to complete reports*
Posted Mar 29, 2021 - 20:33 UTC