United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Tennessee DMV is offline
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 15:37 UTC
Update
The Tennessee DMV is back online and MVRs are now processing.
Posted Jun 01, 2022 - 15:31 UTC
Identified
The Tennessee DMV is offline and MVRs in the state are not currently processing. We are in contact with the DMV as we aim to restore service as soon as possible.
Posted May 31, 2022 - 17:09 UTC