United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Kent, MI
Incident Report for Checkr US Data Status
Resolved
10/19/2021: The Kent, MI courthouse is back online and searches are now able to be processed.
Posted Oct 19, 2021 - 20:57 UTC
Monitoring
10/15/2021: The Kent, MI courthouse system is still experiencing outages, and searches are still unable to be processed. We are continuing to monitor this and will notify you of any changes. The estimated percent of impacted reports is 0.28%.
Posted Oct 15, 2021 - 19:30 UTC
Identified
10/13/2021: The Kent, MI courthouse is experiencing outages and our researchers are unable to complete searches at this time. There is currently no ETA for when this will be back up, but we will continue to monitor this and notify you of any changes.

*This will affect all searches*
Posted Oct 13, 2021 - 19:17 UTC