United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Minnesota DMV Maintenance 9/10-9/12
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 16:14 UTC
Identified
The Minnesota DMV will be offline on Saturday, September 10th at 6pm CT until 6am CT on Monday, September 12th for scheduled maintenance. MVRs ordered during this time will be completed once service is restored.
Posted Sep 08, 2022 - 20:45 UTC