United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Multiple DMVs are offline
Incident Report for Checkr US Data Status
Resolved
All of the DMVs noted are back online and MVRs are now processing normally.
Posted Jul 05, 2022 - 01:39 UTC
Identified
The following DMVs are offline and MVRs are not available in these states: WV, OK, AR, IA, ME, NE.

We have reached out to the DMVs but, given the holiday, we do not anticipate responses until Tuesday, July 5. We will provide updates as they become available.
Posted Jul 04, 2022 - 21:49 UTC