United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

KY Courts Closed due to Storms
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 20:08 UTC
Update
12/21/2021: The Graves, KY county courthouse is still closed until further notice due to the significant structural damage they experienced during the storms. Other county courthouses listed below have reopened, please expect some delays as they recover. We will continue to monitor these closures and update you as we know more.
Posted Dec 21, 2021 - 18:52 UTC
Monitoring
12/14/2021: There have been some updates to the court closures in KY below. We will continue to monitor these closures and update you as we know more.

-Graves, KY: The courthouse has experienced significant structural damage and will be closed until further notice for repairs.
-Marshall, KY: Closed due to power loss, and the currently estimated restoration is 5-7 days.
-Warren, KY and Henderson, TN: The courthouses are without power, all searches are unable to be completed. There is currently no ETA for when power will return.
Posted Dec 14, 2021 - 21:35 UTC
Identified
12/13/2021: Some courts across Kentucky have been affected by the recent storms.

-Graves, KY: The courthouse has experienced significant structural damage and will be closed until further notice for repairs.
-Marshall, KY: Closed due to power loss, and the currently estimated restoration is 3-5 days.
-Please see some possible delays in Warren, Muhlenberg, and Meade counties as well.

The current estimate of the affected reports is .01%. We will continue to monitor these closures and update you as we know more.
Posted Dec 13, 2021 - 16:52 UTC